Navigation

Upgrade the Kubernetes Operator from Prior VersionsΒΆ

Upgrade the MongoDB Enterprise Kubernetes Operator
Upgrade the Kubernetes Operator to its latest version.
Migrate to a Specified Application Database Version (Required for Version 1.11.0)
Migrate the Application Database to the latest MongoDB version.
Upgrade from Kubernetes Operator 1.12 with TLS Enabled
Migrate opaque TLS secrets from Kubernetes Operator 1.12 or earlier to secrets of the kubernetes.io/tls type.