Docs Menu
Docs Home
/
MongoDB Database Tools
/

mongostat Compatibility and Installation

On this page

  • Compatibility
  • Installation
  • Learn More

This page describes software compatibility and installation for version 100.9.4 of mongostat.

Starting in MongoDB 4.4, the MongoDB Database Tools are released separately from the MongoDB Server. The MongoDB Database Tools use their own versioning, with an initial version of 100.0.0.

mongostat version 100.9.4 supports the following versions of the MongoDB Server:

  • MongoDB 7.0

  • MongoDB 6.0

  • MongoDB 5.0

  • MongoDB 4.4

  • MongoDB 4.2

While mongostat may work on earlier versions of MongoDB server, any such compatibility is not guaranteed.

mongostat version 100.9.4 is supported on the following platforms:

x86_64
ARM64
PPC64LE
s390x
Amazon Linux 2023

Amazon 2

Amazon 2013.03+

Debian 10

Debian 9

Debian 8

RHEL / CentOS 9

RHEL / CentOS 8

RHEL / CentOS 7

RHEL / CentOS 6

SUSE 15

SUSE 12

Ubuntu 20.04

Ubuntu 18.04

Ubuntu 16.04

Windows 8 and later

Windows Server 2012 and later

macOS 11 and later

macOS 10.12 - 10.15

The mongostat tool is part of the MongoDB Database Tools package:

Follow the Database Tools Installation Guide to install mongostat.

← mongostat