Schema view not loading in MongoDB Compass

HI kanikasingla,

I’m experiencing the same issue, I’m not seeing any Schema or Validation views.
I am using the latest version of Compass and have tried everything you have suggested on this forum so far but still having the issue.

Hi Zack_67637,

Are you using Stable version and not any other Edition? If you have multiple editions installed, make sure to open the right one.

Please share the screenshot.

Kanika

Hi Kanikasingla,

Thank for getting back to me, yes I am running a Stable version.
Below is screenshoot.

Here is one more way to see this:

Which Icon are you able to see for Compass? If it is the first one, I would recommend you to open a JIRA ticket on mongodb. Here: https://jira.mongodb.org/secure/Dashboard.jspa

Kanika

Hi Kanika,

No it is the third image that I am using.
image

image

Hi Zack_67637,

Thanks for sharing the information. Please uninstall this one and download the Compass Stable version.
It should look like the first one.

Kanika

Having the same issue descrived in this thread. I’m using 1.16.3 as you can se in the sreenshot and also you can see console log with the error just in case it helps to find where the problem might be.

This isue happens with some collections, for instance ships.shipwrecks one. With video.movies i managed to get the schema view correctly as you also can see in the second screenshot i attached.

Thanks in advance.


Hi @Kanika,
I have also Community stable version 1.16.3, but not able to see Schema TAB in it,
Need your help. Thanks.

Community and Stable version are different. Install STABLE version.

54%20PM

1 Like

Yes @Kanika, with suggested version, it is visible Schema Tab. Thanks a lot for your support.

Hi,

I am using Compass version 1.16.4 (stable), still not able to see Schema view.

@vishalkarelia,
Kindly provide the compass version screenshot from your device?

@vishalkarelia,
Here it clearly shows that you have installed Community version. You could see several topics and also in this floating topic queue regarding the same issue. Could you please try Stable version and kindly do succeed.

1 Like

Hi Arjun_92068

I had the same problem and tried everything that is said in the discussion, what worked for me was to close the application and reinstall it (do not uninstall the previous one) and when I started again I could analyze the schema.

Hi,

I have version stable 1.17.0, I’m on Windows Server 2008 R2 Datacenter, actually I’m on an Amazon WorkSpace located in Ireland. My bandwith is around 500mbps in both up and down direction with a ping of 1ms.

I’m not able to load the schema analysis for the collection 100YWeatherSmall.data
I’m able to load the schema for video.movies, but only if it’s the first thing I do after launching the application.

I did tried to relaunch the app, press ctrl+f5 (did nothing), I tried to clear the content of folder AppData\Roaming\MongoDB Compass\Cache, I did tried to reinstall the application, nothing helped.

I’m currently unable to pass the labs of week 1, this courses serves as an evaluation of your products. Currently I can not go further and I will fail this week assignments due to known bugs (since at least 4 releases if I read this post) in your “stable” version.

Please provide a solution.

PS/ I’m using Amazon WorkSpace to connect because your application is not able to reach internet trough a corporate proxy.

Hi cdeloeul,

Sorry for your experience. Here is one solution suggested by another:

Hi, if using windows, close the Compass and start with “Run as Administrator”.
worked for me

If that doesn’t work, please reinstall Compass and let me know what happens.

Also, share the screenshot of the issue.

Kanika

I’ve the same problem. Can’t see any schema tab

Hi,
I downloaded the stable compass version (1.17) but reading the documentation I discovered that a subscription is needed to be able to use it:
“All versions of MongoDB Compass are free to download, but non-community editions are reserved for users with an enterprise license.”
So I must pay a subscribtion to use it for the course?

thank you

I got the same problem Version 1.17.0 and no schema tab available. How do we proceed?