Schema view not loading in MongoDB Compass

I am using MongoDB Compass 3.6.8 Enterprise edition.

Schema view is not loading for me. I clicked Analyze Schema button, It shows blank after analyzing data.

1 Like

Hi Arjun_92068,

Make sure you don’t have anything in your Filter section and it shows some documents.

Try restarting compass and make sure your internet connectivity is good.


Same as me Arjun_92068 , no schema view at all, restarted like Kanika suggested but nothing changes.

I am stuck with the same issue, unable to get the correct answers for the quizzes. Some one please address this issue.

I tried these, My internet connectivity is good as well. still schema is blank

Are you all using Compass Stable version 1.15.4 ? And not Community or Enterprise Edition.

1 Like

yes, I am using compass stable version 1.15.4.

Yes, I am also facing same issue!!!

Hi Everyone,

Please let me know your OS specification on which you are using Compass.

Make sure you use Compass Stable version 1.15.4 .

Also, your filter section should be empty.

Thanks, Kanika

OS: Windows 7 Professional (64bit)


Schema not viewable!!!

Hi Sanket_01272,

You have message appearing 0 documents. Are you sure you have data in video.movies ?

Please remove any Query mentioned either in Filter or Aggregation.
Then, let me know what happens when you click on Analayze Schema ?


Just Nothing, please fwd this issue to authority!!!

It worked first time then no response!!!

Thanks Kanika!!! I reinstalled it, now it worked for first time and then again blank screen!!:roll_eyes:

Let me see what I can do regarding this problem. :frowning:

Sorry for the inconvenience caused!


Hi Everyone,

This problem is because of caching in Compass. Until we find a permanent solution, please try refreshing the Compass data. You need to press

  • [ctrl] + F5 for Windows
  • [cmd] + r for Mac

Thanks, Kanika

This is what i see in my compass:

but for community edition no such error but neither is schema viewed.

HI kunal_76665,

Have you tried everything mentioned here .
If you are still having trouble, let me know.

Thanks, Kanika

Dear Kanika
I reload the data also clicked the ctrl + F5 on windows but still schema tab does not show results
My compass version is 1.16.1