Schema view not loading in MongoDB Compass

Hi Mousa_84706,

Please share the screenshot of the schema tab. I believe you are using Stable version of Compass and your network connectivity is good.

For safe side and try once more, restart compass, open the schema tab right away (before filter). Wait for it to load.

Let me know!


solved the issue by downloading graphic driver
check in your browser if webgl and webgl 2.0 is hardware accelerated or not

by the way it doesn’t automatically loaded I have to click the analyze schema button

Hi Tanuj_61493
I have enabled webgl hardware acceleration.
Compass is an electron app. there is a chromium app is installed alongside with Google chrome which I think is outdated. I am using windows 7 I’ll check in mac too.
I wish a more complete GUI tool from mongodb. I’ve tried Navicat for mongodb which is good

I’ve successfully loaded the schema using navicat for mongodb in the same computer which compass installed. it took around 1 minute to load the scehma graphs completely. I will check with a higher speed in mac and we’ll report here

1 Like

Thanks for the tip, Kanika!

I was having this issue because i was using community edition. After reintalling from 1.61.1 (stable) channel i was able to access the schema tab.

1 Like

You just need to click on Analyze Schema, so that the data is loaded into the view

1 Like

My one have the same problem, but there’s no SCHEMA tab in my one.

Qual versão do compass tu baixou?


A community não tem a funcionalidade do schema!

Baixe a 1.61.1 (stable).

Depois de finalizado o donwload, reinstale (uninstall antigo/ install novo) o compass usando o novo instalador e quando tu abrir a conexão o schema (e várias outras funcionalidades) vai estar lá.

1 Like

Deu certo aqui. Valeu!

1 Like

I encountered similar issue. Try to restart the MongoDB compass desktop application.

I am using community version and i am not seeing schema tab when i click on collections,

should i be install regular version , downloaded community since it was free. please guide me

1 Like

I also downloaded the Community version, and I don’t have a schema tag.

Guides I’ve read say that the Schema tab is only available on the full version.

‘schema’ tab is still missing, repeated the entire connection steps twice, reloaded the app etc. I’s just not there


Ok, now as I installed the full version of compass, not the community, ‘schema’ suddenly appeared. I think it’s just not available in the community version


i see the lesson has community version ( top right corner). for some reason i installed community but it is showing as enterprise on top right corner. that could be the problem. may be i should try reinstalling again.

Kiran kumar **

I tried reinstalling , but still no luck. I am attaching the screen shot.

Hi Everyone,

Please install Compass Stable version 1.16.3 here.