Docs Menu

Compatibility

This page describes the MongoDB and driver versions with which Client-Side Field Level Encryption is compatible.

Automatic encryption with Client-Side Field Level Encryption is only available with MongoDB Enterprise Edition, version 4.2 or later.

Manual encryption with Client-Side Field Level Encryption is available with MongoDB Community and Enterprise Edition, version 4.2 or later.

Client-Side Field Level Encryption is only available the following official compatible driver versions or later:

Driver
Supported Versions
Quickstarts / Tutorials
3.4.0+
Node.js Quickstart
3.12.0+
1.13.0+
3.10.0+
2.10.0+
1.17.5
1.2+
2.8.0+
1.6.0+
2.12.1+

Please refer to the driver reference documentation for syntax and implementation examples.

←  ReferenceLimitations →
Give Feedback
© 2022 MongoDB, Inc.

About

  • Careers
  • Investor Relations
  • Legal Notices
  • Privacy Notices
  • Security Information
  • Trust Center
© 2022 MongoDB, Inc.