Some clients reporting "cannot find app using Client App ID"

This happens to me right now for some reason.

Some clients report that they got this error:

21:27:19:58
2021-05-21T18:27:20.131Z	c792ac33-3292-44c3-a1e7-b0dd21aaca00	ERROR	{
  message: "cannot find app using Client App ID 'timeless-is-***'",
  code: -1
}

But, other clients can access our app with no problems.

Here’s the code that we use:

  const realmApp = new Realm.App({ 'id': 'timeless-is-***' })
  const user = await realmApp.logIn(Realm.Credentials.anonymous())
  const db = user.mongoClient('mongodb-atlas').db('timeless-is')

Versions:

  • Node: 12.10
  • Realm: realm@10.4.1

No idea how can I fix this :slight_smile:

1 Like

Hello Nikita,

Welcome to the MongoDB Realm forums! I would love to help you with this, I just have a few clarifying questions.

  1. Is this for iOS or Android, or both?
  2. Have you tried verifying the app ID and restarting sync yet?

Thank you,

Brock.

Also note:
Moya kirillitsa ne samaya luchshaya

Tem ne meneye, ya ne protiv pomoch’ vam lyubym sposobom, kotoryy vam budet proshche vsego.

Hello Nikita,

Other question for follow up, are you able to gain access to realm console via http://cloud.mongodb.com/ ?

Thank you,

Brock

I’m having the same issue where it says
cannot find app using Client App ID

i created another app to check and replace that id still same issue.

I also used url authentication https://realm.mongodb.com/api/client/v2.0/app/<my-app-id>/auth/providers/local-userpass/login.
but still the same result.

1 Like

Hey guys, I’m facing the same issue, and haven’t found any solution on the internet. @Safik_Momin @111522 Did any of you found a solution?

1 Like

I have same problem too. Any one have a solution?

2 Likes

It looks like this is not fixed yet, right? I just created an App and enabled the Data API … but, am getting the same exact error when trying a sample POST from postman

{
“error”: “cannot find app using Client App ID ‘the-app-id-here’”
}

Can anyone from Mongo reply please? Thank you.

So … disabling drafts under Deployment->Configuration solves the problem … kind of. Certain clients can connect while others continue to get the error …

Also, possibly having App Settings → Deployment Region global works better than local (though, I am not sure that you can make this change after the app is created). Glad this is all “GA” …

Hello Mongo,

It looks like there are a ton of views on this issue and it looks like it has been out there for a while. Is there anyone looking into this issue? Is there a bug number that we could follow to track any progress?

Also, it would be nice to understand how Mongo reviews these communities and why something like this might sit for this long, without any comments. Am I just missing them?

Thanks,
Steve G

Same here. But if you continually try to log in, it works. This means you can try to keep login at least twice, interesting,

G’day Folks @Dima, @Steve_Gaylord , @Haikun_Huang, :wave:

Welcome to MongoDB Community :blush:

I appreciate you raising your concerns and apologies for the delay. The replies to an old topic are sometimes not visible in the queue.

There is not a single reason for this error to happen. Deployment Region, internal SDK URI mapping, etc could be some possible reasons. Unfortunately, on June 02, 2022, during our regular release cycle, a bug got introduced that caused locally deployed apps not to be found. The bug was isolated to a limited number of apps in a subset of regions. This has been fixed since.

@Dima, could you please let me know if this is happening in your prod or dev environment and what is the app name it is happening for?

@Haikun_Huang could you please share the app name where this is happening? Your app logs are not showing the error. Could you confirm if this is fixed for you?

Best,
Henna

2 Likes

Hello,

First of all, thank you @henna.s for replying and shedding some light both on this issue and your process for responding to these threads.

I hope that you all change the way you monitor the queue because old issues, especially popular ones, are sometimes the most troubling.

This was happening in dev, but we resolved the issue the way I described above by changing the deployment region to global.

Was there visibility into this bug? Is there a good place to search for open bugs?

Thank you!

Hello Dima,

Thank you for your reply and appreciate your feedback. It’s always helpful to know areas where we can improve.

Could you please share the time period when this was happening? What SDK are you using? What local region was your app deployed and what is the cluster location? There may not have been a need to change the deployment model but glad to know this was resolved for you.

The SDK issues are available to search on Github based on the language stack you are using but the cloud issues are internal unless there is an outage that gets highlighted on the respective status pages.

Kind Regards,
Henna

1 Like

This was at the time of the reply to the original post, around June 16th, 2022.

No SDK; just postman POST to the Data API endpoint.

The app region initially was the one it defaults to … I believe in our case that is AWS us-east-1 (same as the cluster location)

As far as not needing to change the deployment model, I disagree. It simply did not work (as per the post) when the deployment region was local instead of global.

It would be great to see cloud issues somewhere; this way, if anyone runs into a problem, you can at least see if it is a known issue.

Thank you.

Hello Dima,

Thank you for your patience and apologies for the delay in getting back to you.

This definitely should be a one-off, perhaps a residual effect of the bug that unfortunately was introduced. Could you try again with a test application with local deployment?

Your feedback is definitely noted, but since this was an internal issue and was fixed rather immediately, this was not highlighted.

Please let us know if you would have any more questions or if it is fine to close this topic.

Happy Coding :smiley:

1 Like

This does work now. Thanks.

1 Like