Mongosh on W7, error about GetHostNameW at WS2_32.dll

I’m at MongoBasics course (Chapter2 as far) I can conn at IDE and by MongoDB Compass, but I would like to follow find() example, thus I need MongoDB shell. No success. I tried the .zip installation ( The procedure entry point GetHostNameW could not be located in (…) WS2_32.dll ), reading an entry at this forum I uninstalled mongosh and installed from .msi file. But with same result.
Any suggestion? If installation it is not possible Which other way (tool) I can test something as simple as “show db” command?
Thanks in advance and B.R, Lorenzo

Hello @Lorenzo_Hombria!

Windows 7 is an end-of-life platform, and as such, mongosh builds do not support it.

You can use the legacy shell, mongo, to interact with the server, from Download MongoDB Community Server | MongoDB. The last version of it to have official Windows 7 support is 4.2.x, so be sure to select an older version there as well, instead of the most recent one.

1 Like

Hello Anna
“Muchas gracias” I got the server version 4.2.17 and with the mongo.exe to build a .bat to connect with my Cloud test cluster. Now I have to work with other commands like “show db” and “find()” but the problem is another one, I’m in, that’s the point.
Thanks again. Have a nice day, Lorenzo.