Mongoimport command not found for MongoDB 4.4.0 server installation on macOS

I tried importing a json file to my Mongodb atlas by running a mongoimport… but got a message that states: zsh: command not found: mongodb. My Mongodb version is 4.4.0, My OS is Catalina. When I ran ls “$(which mongo | sed ‘s/mongo//’)” | grep mongo, I got a list of mongo, mongod, mongos. I have also tried reinstalling and I keep getting the same responses. Please help.

Hello @Eze_Amadi,

You can download the MongoDB tools separately at Download Database Tools. As of MongoDB 4.4, the server tools are also packaged separately and have different versioning.

Also, the documentation for mongoimport is found at a different location (as Database Tools), not as part from the server documentation: mongoimport.

1 Like

Hi @Eze_Amadi,

As Prasad noted, the Database Tools are now separately versioned and installed as of the MongoDB 4.4 server release.

The macOS installation guide and MongoDB Homebrew Tap should be updated to reflect this change, including information on how to install these tools if needed.

I have raised a few related improvement suggestions you can watch and upvote:

In the interim, you can download the Database Tools via the MongoDB Download Centre as Prasad suggested.

For more background on this change, please see Separating Database Tools from MongoDB Server (July, 2020).


I just noticed there is already a pull request in progress to update the Homebrew README.

The following worked to install the latest version of the Database Tools:

brew tap mongodb/brew
brew install mongodb-database-tools


It worked. Thanks to everyone that helped with this. I really appreciate!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.