MongoDBError Error After Upgrading To M10 From Shared

Hi, I have upgraded our cluster from Shared to the M10. However, our web application no longer connects. I do see a set of errors on the Realm Logs.


I assumed a migration to a dedicated cluster should be seamless and our app should have connected without issues. Now we have clients not able to see their data and we are not sure what to do. Any help would be appreciated.

Hi @Sani_Yusuf ,

I assumed a migration to a dedicated cluster should be seamless

No, updating from a shared to a dedicated cluster isn’t seamless, and has indeed a documented procedure to go through. Shared and dedicated clusters have a completely different structure, and some processes need to be redirected.

If you have Device Sync active, Terminate and re-Enable it, and try to re-assign the Data Source. If that still doesn’t work, we’d have to look into the setup, so we’d need to know some more details (like, app ID and such): if you have a Support contract, opening a case would speed up resolution.

1 Like

Hi,
I dont have SYNC. I only have a realm-web application. The documented procedure is similar to what I followed, as the SYNC side doesn’t apply to me. Any Ideas?

Hi @Sani_Yusuf

Any Ideas?

Yes, plenty of possibilities there, but we’d need to have a look, a screenshot of a list isn’t much to work on…

Again, any further detail about your app is needed here: I can understand you don’t want to put too much on a public forum (hence the suggestion to open a Support case, if you can), but we’ve to start from somewhere…

Never mind, I’ve been able to find the app, looking into it now: is there any additional detail you can share?

Hi Paolo, this is all I have is this as its the only error. I have clients unable to use the app and its scary because this migration should have been seamless but on this occasion, I think I may have found a bug. All I can tell you is the Cluster was upgraded from Shared M1 to M10 hosted on Amazon in London.

Have you tried what I suggested, i.e. changing/re-assigning the Data Source? At first, you can do a simple change (like, toggle the MongoDB Connection String and save the change), and if that doesn’t work, deleting and re-assigning it from scratch.

1 Like

Hi Paolo, Looks like enabling the String makes everything work. I think this should either be documented or be escalated as a bug which should be fixed as it has terminal consequences for applications using realm-web. . Super thanks

1 Like

That’s great @Sani_Yusuf ,

Glad I could be of help.

No, the Connection String change was a workaround to force the setup to re-evaluate the Data Source the app wasn’t able to connect to, you can toggle it back now.

Yes, the problem may well be a bug, I’ve opened an internal ticket for that, thanks for your collaboration, hopefully it helps others that may incur in the same issue (better for it not to happen anymore, obviously)

1 Like