Mongodb compass- freeze on activating plugins

after installing compass, i ran the program but it only get to the point where it is “activating plugins” but never goes beyond this and the circle "loader keeps on turning but nothing happens … hours and hours can go by, i can restart my machine and still everytime i run this program it gets to the same point the does not go any further than “activating plugins” …

someone please help!!!

Hi @Angelo_Hedley can you please provide a little more information:

  • Version of Compass
  • Operating System

Hello @Angelo_Hedley

Do you see any errors when you click ALT+CTRL+I and check out the console tab on the right side?


1 Like

HI Doug

It only gets to the activating plugins then it does not go any further
Windows 7 i7 HP ELITEBOOK 8560p
1.21.0 (Stable )

HI there, I’m experiencing the same issue and look forward to getting a resolve. I’ve uninstalled and reinstalled Compass and still get the same result.

Hi @Charlie_Maru, we are looking into the problem but we are having some trouble reproducing it.

Can I ask you to do a quick test? You should have all the Compass user preferences in %APPDATA%/MongoDB Compass. Can you delete that folder (make a copy of it in case you have something that you want to keep, like favorite connections or query history) and start Compass again?

Hi @Massimiliano_Marcon
I’ve done as you’ve suggested but it still stalls at “Activating Plugins”. It goes no further.

Thank you for trying. That’s helpful to at least exclude one cause.
I will keep you posted as we make progress with this issue.

Hi, I am also having this problem!

I also have this issue…

Hi @Alfredo_N_A, @Gabriel_Timofti,

Welcome to the community! If you are experiencing the same issue please provide some additional information to help us track down the problem:

  • Compass version
  • O/S version
  • Any other details that might help reproduce down the problem (for example, is this a fresh install or an upgrade from a specific prior version that was working)


Hi. Thx for Response.
version: 1.21.0 (Stable Community)
Os: Win 10 x 64
It’s a fresh install.

I’ll keep updating the status

1 Like

I just borrowed my son’s Windows 10 machine to test and Compass opens up just fine for me. I did notice that there are three packages that can be downloaded for Windows.

  • Exe
  • Zip
  • MSI

I downloaded the EXE package. @Gabriel_Timofti, @Alfredo_N_A and @Charlie_Maru can you verify which package type you’re using? I wonder if it might be a problem with the MSI by chance.

1 Like

Hi Doug,

Thank you for your email. So “what is a bear’s favorite drink? = koka-koala!”, I downloaded the MSI package. Keep in mind I am following the MongoDB University slides at the moment, maybe that’s a great place to start.

Semper fi,

Hi Stennie,
Mongodb 1.21.0
Win 10 x64
I’ve had mongo for some time, and only recently (3 weeks ago) it started to lock up when activating plugins

Hi @Charlie_Maru, Compass 1.21.0 was released on April 28th (about two weeks ago). Is it possible that you updated around that time? If so it’s possible that the update did something. If you didn’t update then hopefully the MongoDB engineers can help you track down what’s going on.

Last week, we released Compass 1.21.1. It should fix some error conditions as well as print some useful error messages in the console of the loading screen if something goes wrong. Could you please give that a try?

Thank you!


i was told to use the isolated edition instead until the problem is fixed. it works out ok but how will i know when the problem is fixed? who will let me know ?

@Angelo_Hedley would you be able to try 1.21.1 (non isolated edition)? We fixed some of the potential issues in there but we’ve had a hard time reproducing the issue in our windows boxes. It’d be great to get some feedback from the community on whether the problem is really solved.

Quick update: we found the problem and fixed it. We will release Compass 1.21.2 with the fix very soon.

Thank you for the patience.