M2 Cluster Slowness

Hi everyone.

I am using M2 Tier Atlas Cluster.

Current billing period is 01/01 - 02/01.

When I send list all request to API (.netCore) 2.5k data response in 1.4 minutes. It is extremely slow. But two days ago everything was normal. (2.5k response in max 10 secs ).

API running on Azure. I tried to restart it. Same result.

I thought that slowness caused by Azure, then tried to connect with dev env to Atlas, nothing changed.

Does anyone have an idea of ​​what’s going on?

Hi @Agah_Gurer1 - Welcome to the community.

It’s possible you may have hit a operational network limit for the M2 cluster. However, this is just a guess based off the provided symptoms you’ve described. You can possibly check with the Atlas in-app chat support team if you’ve hit this limit in the last few days.

You can also try make an M0 cluster and perform similar tests from your environments to see if the slowness is replicated. If not, then this may be another indicator that the specific M2 cluster you’ve mentioned has actually hit the Data Transfer Limits mentioned in the above link. More specifically this is:

  • M2 : 20 GB in and 20 GB out per period