Installation the lower version of mongo-community on mac

Hi, guys.
I have tried to install the lower version (specially 3.4) of mongo-community by homebrew on my Mac.
but there is no mongo-community v3.4 in brew list and 4.2 is minimum version.
Please let me know if any solution.


Hello @Kelvin_Rivero and welcome to the MongoDB community.

MongoDB 3.4 is old and had an end of life date of January 2020. I would caution against using this version, even as part of a test platform.

If you really want to use MongoDB 3.4 you can still find that on the MongoDB downloads page. Just choose 3.4.24 from the version dropdown:

If you’re looking for a specific verison of 3.4 that is not the most recent, you can click on the Archived releases link on that page and then install any version clear back to 2.6.

1 Like

Hello, Doug_Duncan.
Thanks for your fast reply.
I’ve been using v4.2 but the project what I am working asks for v3.4 or below.
I installed v4.2 using homebrew and tried to install v3.4 but brew doesn’t support that version anymore.
By googling and stackoverflow, I tried to find the way to install the lower version of mongo manually but didn’t yet find the good solution.
Would you give me the guide for that?

All the best,

MacOS installation from tarball for MongoDB 3.4. This will explain the manual steps for installing MongoDB 3.4 on your Mac.

One thing to note here is that you will have to use the older mongo shell to interact with this version of the database as the mongosh shell, and recent versions of Compass, requires MongoDB 3.6 or newer. If using any of the MongoDB drivers, I will assume you need to find an older version of the driver as well.

Again, if this is for a production environment, I would heavily push to be able to use a newer version of MongoDB.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.