Atlas Serverless with Realm web app?

I created a serverless atlas instance, and then tried to connect my real web app to it, but i found that the serverless instances were not listed… Can realm apps use atlas serverless instances?

Also, when creating a global real-app what does this actually mean? Is the database copied to various (4 i think) edge locations around the world, hence shorter response time? Is this similar to 1 origin server and 4 sharded servers?

Hi @Rishi_uttam ,

Serverless instances cannot yet be supported as linked source for realm apps. Keep posted on realm realese page.

When an application is deployed globally, the application components (functions, values , services) are placed in all available regions.

The writes are eventually always routed through the write region and this one should be placed where the primary of your replica set cluster is located.

Thanks
Pavel

1 Like

Hey @Pavel_Duchovny. After World last week I set out to try this on some unreleased apps, especially since the marketing here says that Atlas Device Sync (Realm Sync) now works with Serverless.

I’m still seeing it grayed out though. Is there a target date to actually do what the marketing is saying?

Did marketing just jump the gun or is it significantly delayed? Thanks.

–Kurt

For reference: https://twitter.com/kurtlibby/status/1535815477938855941?s=20&t=19E6Qw9qtjmi1pwcYLZDYQ

1 Like

Hi @Kurt_Libby1 ,

I believe it is released now as I can link App Services to a Serverless instance.

Thanks
Pavel

Hi @Pavel_Duchovny,

It does seem like they’re getting closer, but it is still not usable.

When selecting the cluster to sync on, the serverless option is still grayed out:

I can link it, but it will not work for sync.

Oh I see what got you confused @Kurt_Libby1 ,

The device sync service is serverless as it is part of app services on Atlas side. But the page doesn’t mention it works with serverless clusters (that’s a different product than serverless services and backend)

So sync works with dedicated and shared clusters for now.

Thanks
Pavel

I need this feature as well!

Hey @Mark_Vrahas! Welcome to the forums.

It would be super great, but I’m sure there are some technical difficulties here, otherwise they would have rolled it out at MDB World last month.

@Kurt_Libby1 and @Mark_Vrahas ,

You can keep up with the up to date limitations:

Thanks