Atlas Search Practice Lab keeps failing

I was doing the Lab: Creating a Search Index with Dynamic Field Mapping where I am supposed to register with the given token. I did that and returned tot he CLI and it asked me to select an organization and project. I did that and selected the mongodb university one (which I had created for this courses). It keeps failing no matter what I did. Then I created a new one, with the exact cluster name, user, password and access that the questions tells me and then chose that one when prompted after registering with the token. Yet, it keep failing. I have no idea what to do. there is no hints or anything. Please help.

1 Like

not everyone has taken that course nor remembers where the page you mention is.
so please give the link to that lab so we can find which one it is without wandering tons of pages of MDBU content.

1 Like

Sorry about that, here is the link: MongoDB Courses and Trainings | MongoDB University

Hi @Satyam, Can you please ping a “learn” team member? I tried a few things and neither I could not pass this step. so, either the instructions are missing a crucial part, or there is a bug in validation.

also here are some small problems I noticed:

  • videos talk and practice on Atlas UI, but labs use Atlas CLI. makes it a bit difficult at times.
  • CLI-created user gets “admin” role while the lab states to have “read write any database” but does not say how to change.
  • do instruqt’s virtual machines get static IP? I guess it would be better to add “access anywhere” instruction.
  • “check” button return a fail but without any message about why.

Also having this issue. I had to create a new Project and new cluster with their given info (took me WAY too long to find out I wasn’t doing this part incorrectly), but this only changed the error to: “FAIL:”. However, it’s still not allowing the lab to pass. If you go into the settings of the cluster it automatically has the cluster marked as readAndWrite enabled for their default account, so there’s no issues there.

Unfortunately, they don’t allow you to skip this one… So, we’ll have to wait until it’s fixed.

The instructions for this lesson in particular are very unclear.

Also having this issue after recreate the cluster as they ask for (as Andrew_Dutson).
I have written to and I am waiting for the replay.
If anyone knows how to fix it, please post it here…

Found the solution:

  1. You CANNOT have more than one project on the account you’re using. They just added a new error message that clarifies this now.

  2. I just created a new account, if you only have the account that you’re learning on, then you can simply delete your current cluster and then project and start over as well.

  3. Then you create a new project and cluster with the information given in the lab.

  4. Add the sample data set like they instructed in unit 2.

  5. Once this is done you authenticate this NEW account with their cluster information and it passes.

@macabea @Sagar_Subedi

I appreciate the effort of the fixer as the new error messages are better, but absolutely not a solution to the problem at hand.

So now, it tells me I have multiple organizations:

Error 1: Identified multiple Atlas orgs … create a new dedicated Atlas account

I got 2 and then I tried to move MDBU projects into the other so I would have a single organization. Now, the error shows another face:

Error 2: Identified multiple Atlas projects … create a new dedicated Atlas account

I would accept going with a single organization, but this is something else. It basically asks you to have only, and only, 1 organization and 1 project in it for your whole MDBU experience.

The proposed solution of opening a new account, which requires a new e-mail address, along with the implied solution of deleting all other projects for “learn” users, is simply NOT acceptable. This unit, and similar ones requiring the same, will be my first ones to completely abandon.

Hi again @Satyam , I am sorry if I am giving headache :frowning_face: Correct me if I am wrong, but in my opinion, this behavior is against the spirit of MongoDB I have experienced past few years.

I am hoping this situation is just “temporary” and a better fix is on the way.

Hey @Yilmaz_Durmaz,

Thanks for bringing this to our attention. Will take this up with the concerned team. Since @macabea has already mailed the issue to, I’m sure someone from the University Team would have already started looking into it. :smile:


1 Like

Thanks @Yilmaz_Durmaz for your feedback, we’ve implemented a prototype with less rigorous checking/requirements that we hope to deploy to the existing labs this week. Unfortunately, we will still have some hard requirements as without these we cannot provide the seamless learning environment experience as it depends on these requirements to provide the underpinning automation in our lab infrastructure.

It is still our belief and recommendation that you create a separate account for your learnings as it helps ensure there is no possible overlap with existing production or development environments. I realize this may not be the case for many learners but for that subset, we feel it is particularly important to provide guards/rails to avoid any accidental issue/command impacting these important environments. If in the future, these looser restrictions in terms of the lab checking do cause issues with such environments, we equally will revisit the restrictions.

I do thank you for your input and hope you appreciate that the team is balancing many different aspects as we implement our new labs.

Kindest regards,


Thank you @Eoin_Brazil, for the heads up. “learn” is already a great place with you guys behind it. And as a learner of the “old” MDBU, I love testing it (while also learning new things).

My suggestion here would be, instead of a new account (and single organization/project), to force users to have an organization with a predefined name, such as “MDBU Learning”, and have them create project resources in it with, again, predefined names for the sake of lab validations (just like you do with cluster name and username/password). And not just for a few labs, but all over the “learn” experience.

Thank you very much.
I had two projects. I removed the one that didn’t match the instructions of this lab, and It passed the checks (or may be it was because of the changes made by Eoin_Brazil).
Anyway, thank you for your help.

1 Like

I am getting this error:
MongoServerSelectionError: Server selection timed out after 30000 ms

This is after pasting in:
mongosh -u myAtlasDBUser -p myatlas-001 $MY_ATLAS_CONNECTION_STRING/sample_supplies

Mind you, the myAtlasClusterEDU is the only cluster I have under project 0 and I authenticated well, as well as passed the first 2 labs of this lesson

Hi :wave: @Sifiso_Lucolo_Dhlamini,

Welcome to the MongoDB Community forums :sparkles:

I suspect you might not have whitelisted the IP address of your client connections to the MongoDB Atlas deployment.

To do so:

Go to and follow these steps:

  1. Go to IP Access List view.
  2. In the Security section of the left navigation, click Network Access. The IP Access List tab displays.
  3. Click Add IP Address.
  4. Add Current IP address or Allow access from anywhere (Not suggested for production environment).

And then try again to connect to the MongoDB Lab. It will work as expected.

Let us know if the issue still persists.


Thank you Kushagra

I had already tried to whitelist for ‘anywhere’ since I had whitelisted my device at the beginning. It did not resolve my problem though. I do however suspect that it had something to do with the different accounts I had open on the same browser (not certain oif that was the poroblem).

At the end of the day, I left it and went to bed. The following day, I decided to open the Atlas account for the lab in an incognito browser (by copying the link and pasting it) and everything went through well. But like I said, I am not sure if that was the problem.

Thank you kindly for your response. It is very encouraging to see the support on the platform. I am here to stay.


Sifiso a.k.a Scifi

Hi :wave: @Sifiso_Lucolo_Dhlamini,

I suspect it might be due to the browser cache or cookies. Clearing these may resolve the issue. You can also try logging out of MDBU and logging back in after clearing your cache and cookies.


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.