Lab errors in Mongo University

I was trying to continue learning about the database after I had done lessons and I had to redo the intro course and I set up a new cluster when I logged with the new cluster the lesson would not let me progress and I got this error:

Incorrect solution 11/11Identified multiple Atlas orgs - 3 - Please create a new dedicated Atlas account for your MongoDB University learnings. Please visit ‘Creating and Deploying an Atlas Cluster’ lab in Lesson 2 of Unit 1, ‘Getting Started with MongoDB Atlas’, if you are unsure of the next steps.

The only thing I do with this account because we have out own professional server. How can I correct this error and take the classes?

Hi :wave: @Joe_Creaney,

Welcome to the MongoDB Community forums :sparkles:

We are aware of the issue and a response from the Education Team can be found here.

As of now, we’ll suggest you create a dedicated Atlas account for MongoDB University.

Let us know if you have any further questions.


1 Like

Hi @Joe_Creaney, There are two options here:

  • create a new account just for the sake of the course. but be careful as you are not allowed to have more than 1 of organization/project to complete at least that lab.
  • wait for a fix and skip that unit/section for the moment.
    • some of the labs use CLI. fortunately, videos seem to show you how to do it in Web UI. follow them first.

Hi again,

The answer Kushgara provided above was about “creating Search Index”. And from the details you have provided, I deduce other units also use Atlas CLI in the labs.

I have, moments ago, tried the lab in the unit I mentioned and it has passed the first check with “1 project in the selected organization” and passed the second check after I moved a few other projects into that organization.

So it is safe to assume this “create new account” problem is solved. However, be aware of possible clashes of projects (as stated in the linked answer) if you do not use Atlas CLI properly in the future with multiple organizations/projects/clusters.

Hi, I am also having similar issues, although I do not get any error message, but the default
“Incorrect solution
Something went wrong while checking your solution”
This I also experienced and skipped in Unit 1, Lesson 2. Now, in lesson 3, I am asked to enter into the learning dedicated account, which I did create, with an authentication token. I follow the steps and am able to succeed. I am asked to go back into Atlas CLI and check my solution but the check fails. I have already terminated original Cluster0 and initiated another free, shared cluster with the desired/suggested name “myAtlasClusterEDU”, added the desired user “myAtlasDBUser” with admin permissions but the check still fails. I’ll open a new thread.

This problem is still there (28 Feb 23). I tried 3 times and nothing seems to work, not even a new auth code or refresh/logout. Strangely enough, the first 2 lessons worked ok with the lab.

I wonder why.
I passed the previous check (create a cluster"myAtlasClusterEDU" with a dedicated user “myAtlasDBUser”. But now, the next check wants me to create a database with two collections (“users” and “items”) and insert one document. After doing this, within the tab opened from within the CLI, I complete the task, return to the instruqtUI but the check fails saying “The expected document in the users collection has incorrect values. Please try again.”. Well, that’s wrong. It has the correct values. Can someone give a helping hand here?

Hi @matheus_malty,

Welcome to the MongoDB Community forums :sparkles:

Apologies for the late response.

To further understand the issue can you share the values you have inserted in the users collection and what command you ran to execute the operation?

Also, can you confirm if this issue has been resolved on your end? If not, please feel free to reach out to us.


Hi @Kushagra_Kesav,

Thanks for your kind answer.

Yes, I had inserted two integers as string, not as int. Once this change was made, the check went through.

Thanks for the support though.

1 Like

@Monika_K , you should be seeing some error messages. please copy-paste the error to help us understand the problem.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.