Accessing data from Atlas snapshot .wt files

A few months ago, I had an active MongoDB database, but for other reasons, I had to terminate it. However, it was a Dedicated tier db so I was able to take an Atlas snapshot of everything inside before it was deleted. The Atlas snapshot gave me a compressed .tar.gz with a restore folder that contained various collection and index .wt files.

Fast forward to now, I’m hoping to be able to access the information within these files for a project I want to do, but I’m incredibly inexperienced with Mongo. Does anyone know how I can access the data within these .wt files without deploying a paid Atlas cluster?

I tried the following:

  1. Copy and pasting all the .wt files into my local dbPath
  2. Starting mongod
  3. Running mongodump --out /path/to/output/directory to get .BSON version of the .wt files

This sort of worked, but all I got was a single folder titled ‘admin’ that had two .BSON files in it:

  • system.version.bson
  • system.version.metadata.json

I would greatly appreciate any help! Thank you so much.

Hey @David_Zhang - Welcome to the community :wave:

Sounds like most of the steps are fine. You don’t necessarily have to copy and paste all the .wt files into your local dbPath. Have you tried starting the mongod instance using the extracted data file directory instead? Example detailed in step 4 of the Restore from a Locally-Downloaded Snapshot documentation.


I tried that just now, but mongod eventually just exits out with an exitCode:62. I’m actually not sure why that isn’t working

mongod --dbpath C:\Users\slash\Desktop\extracted_data\restore-63b11574dbc7f453dc3733f4

Are you using the same mongod version as the backup which was downloaded?

Oh I didn’t know that was a factor. Do you know how I can find out?

I can’t recall any quick way off the top of my head. Perhaps you can log into your Atlas account and check the project activity feed to see what was the last version of your cluster.

It looks like I took and downloaded this snapshot on the 1st of January, 2023. Does this mean I should use mongod version 4.2.23 (

I really appreciate your help by the way. I’m completely new to mongo and I’ve been trying to get this data out for like two days now haha

No worries - Happy to help :slight_smile:

I don’t believe thats a direct indicator of what version was downloaded from your Atlas cluster. You can try a few out and let me know how you go (for e.g. starting with version 4.2 mongod and trying versions before and after).

1 Like

I tried every available version of MongoDB from 3.6.23 to 5.0.18, but all of them gave me errors. 4.2.24, which was the closest thing to the version I suspected I needed (4.2.23), was available and even that didn’t work.

However, I was so desperate that I ended up going on a whim and editing the download link so that it was representative of 4.2.23. I didn’t expect much, but that actually ended up working! I was able to download and use 4.2.23 mongod.

Tried what I was doing before and the .BSON dump finally executed properly.

Thank you for your help! Have a nice day.

1 Like

Thanks for posting that detailed solution for your scenario David. Glad it ended up working again!

Have a good one.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.