Wildaid.github.io bugs: Issues while setting up the repo locally

I have set up wildaid.github.io locally with prerequisites installed. I have a few issues:

  1. Incomplete documentation - The README does not specify the complete steps to set up the website locally. It might seem trivial for people experienced in Ruby and Jekyll but for others, the complete steps would help. I’m willing to update the README if I’m able to set up the repo successfully.
  2. 404 error on visiting the local website - I ran bundle exec Jekyll serve and got a 404 error page. I’m unable to visit any route. This issue might be because of some missing steps during the local setup.
  3. Information missing on the deployed site - I tried to set up the project locally to figure out and possibly fix a few issues I found while going through the O-FISH documentation site. For example, the useWeb page is missing the steps. Also, the bottom navigation seems to have unnecessary brackets.

Any sort of help would be appreciated as I’m trying to fix the problems I encountered while reading the documentation.

UPDATE: I’ve found the solution to point 2 and can work on creating a PR for both 1 and 2. I’m still trying to figure out point 3.

1 Like

Hi @ayushjain - yikes, it’s so hard when the documentation doesn’t tell us everything we need. Which parts aren’t clear? How did you solve #2? I appreciate any efforts to make things better, but I am also happy to spend more time making the build documentation better.

For #3, the usage documentation needs a lot more work - there is no documentation on how to use the web site yet, and the mobile apps are only documented as far as logging in and the home screen.

At the hacktoberfest kickoff meeting I did demos of the mobile and web apps - the recording is at

The mobile demo starts at 13:05 and this until 20:30
Web demo goes from 22:50 through 28:00.

I recommend you watch both demos to get a sense of the purpose of the web app - the mobile app is where information about a boat’s boarding is gathered and inputted, and the web app is where that information is aggregated. When the web app demo talks about ‘a boarding record’, it is helpful to know what that is.

I hope this helps!


Hey @Sheeri_Cabral

Thanks for going through these issues. I’ve filed the point 2 as issue #120 along with the proposed solution. I’ll be happy to make a PR to solve the same.

The clarity of documentation is an issue:

  1. wildaid docs - The Building and testing the documentation part is incomplete. Now that I’ve gone through it, I can file a PR to include all the necessary steps.
  2. Web app - I don’t know where but I remember the documentation of the using web when I first visited the docs a few weeks ago. I tried to look that up in the git history but wasn’t able to find it. Maybe, I saw something else but afaik it was about how to use the deployed ofish website. I’m a bit confused because it’s been a few weeks. Anyhow, I’ll watch the web demo you shared and we can recreate the missing part.

I’ve also RSVPd for the ofish event on 20th. We can discuss more in that meeting. For now, it would be great to discuss some of the solutions I proposed in the issues across wildaid docs and ofish web app.



This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.