When trying to connect in the compass,It is saying authenciation fail

fire wall is not blocking.
ping, tracert and telnet are working.
all the fields are properly checked.
Cant go ahead with the problem,
SomeOne look into the problem plz.Screenshot%20(128)

1 Like

@Rakesh_39108 Have you tried confirming connectivity with MongoShell as well? If anything that would isolate your issue to Compass.


Check password two hyphens

1 Like

I had the same error, before copy and pasting the username/password pair again, and making sure I don’t copy any white spaces…

1 Like

i tried with two hyphens as well. It’s not working.

It worked with below details
Hostname: cluster0-shard-00-00-jxeqq.mongodb.net
Username: m001-student
Password: m001-mongodb-basics
Replica Set Name: Cluster0-shard-0
Read Preference: Primary Preferred

how to connect to mongo shell

problem solved thanks for helping.

1 Like

Dear MongoDB Team,
Kindly Help to Update the video with correct password. As per the video for the following,
Chapter 1: Introduction -> Connecting to MongoDB Using Compass, password is said as “m001-mongodbbasics”.
Thank you for your understanding and support.

Me Too faced the same issue. Then referred the link,
sadly it was not given in the mobile app.

Hi rajcheram,

Thanks for the feedback!

As difficult it is to re-create the lecture videos, but we have mentioned correct password in the lecture notes.


Hi Kanikasingla,
I can understand. Thank you.

1 Like

Thank you so much! It worked fine!