Vm.max_map_count is too low

After going from mongoDB 5 to 6, I noticed in the startup warnings, I now get vm.max_map_count is too low

I never had any issues before with the default values. Is this something that has to be changed? Also, I have /sys/kernel/mm/transparent_hugepage/enabled is 'always'. We suggest setting it to ‘never’, which I also never changed, but never seemed to have any issues.

Thanks

All of the configuration in https://www.mongodb.com/docs/manual/administration/production-notes/#production-notes are recommended setting. If they are not applied performance issues may be encountered in the future.

https://www.mongodb.com/docs/manual/tutorial/transparent-huge-pages/ explains this configuration setting and why it is more performant for MongoDB

1 Like