Version 5.0 Ubuntu Installation Issue

Hello. I am new to this forum, and I apologize in advance if this message is not found in the proper category.

I was wondering if the correct approach to Install Version 5 on Ubuntu was to First, following the instructions for 4.4. When just following the instruction on the Document Page for 5. It appears the wget command works to add the key, though when trying to use sudo apt-get update, it fails stating the public server key is not found.

Thanks in Advance,

Dave Shreve

You have nothing to download or install for the course M001.

Welcome to the MongoDB Community Forums @Dave_Shreve !

For a new installation of MongoDB server you should start directly with your intended version of MongoDB rather than following an upgrade path: Install MongoDB Community Edition on Ubuntu.

Please provide a few more details:


Ubuntu Versions Tried: 20.04, 18.04
Use the Apt-key add- related to the 5.0 version of MongoDb.
wget -qO - | sudo apt-key add -

Below is from the 18.04 version of Ubuntu, replace bionic with focal, for 20.04:

W: GPG error: MongoDB Repositories bionic/mongodb-org/5.0 Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 656408E390CFB1F5
E: The repository ‘MongoDB Repositories bionic/mongodb-org/5.0 Release’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.

I just tried to replicate the issue, by instantiating a new VM for Ubuntu 20.04.
Surprisingly, I did not have the same issue, following the same steps.

Either, I had typo’d something, or was a change made?


Dave Shreve

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.