[Urgent] Cannot build Compass from source (cloned from GitHub) on Windows 10


I’ve been struggling for many hours (even a day) trying to build MongoDB Compass locally on my PC whose OS is Windows 10. I’ve been following carefully the readme file related to contribution (CONTRIBUTING.md).

I am using Node v16 with NPM v8 as requested. When entering npm run bootstrap, the download of packages begins and then suddenly an error occurs:

Each time I repeat the installation (whether through npm run bootstrap or npm i), I keep having this same error. I searched about it everywhere (on Stack Overflow, Github, ChatGPT, even MongoDB forum), but the answers are not applicable to my case. Note also that I deleted node_modules many times and repeated the same process without any success.

I even did the same process with Node v18 and NPM v8 but the same error is appearing… However, the installation continues till the end. Then when lerna is executed, I can see like the repos are compiling (I’m not sure of the terms if they are correct) but then lerna fails (which is expected since the installation was not 100% successful).

Would be glad if you can assist me. I already contributed to Compass in the past but didn’t need at that time to set the whole environment.

Waiting for an answer asap


After having installed everything with Node v18 (as I talked about it in the post), I switched back to v16, then I typed npm run bootstrap. I had the same classic error related to buildcheck, but then, when lerna began its execution, everything succeeded and the electron app opened although there is an error with the installation. Really strange…

We, developers, are used to solve software problems without sometimes understanding what happened exactly :stuck_out_tongue:

In all cases thank you. But please do not delete this question. I may refer back to it if the build doesn’t work anymore.