Unable to run realm-cli, returns node:internal/child_process

When I try to run realm-cli I get node:internal/child_process everytime, no matter what i do. I tried reinstalling, using different node version, previous mongodb-realm-cli version, same error. I’m on new Mac M1, using zsh and nvm

$ realm-cli whoami
    throw errnoException(err, 'spawn');

Error: spawn Unknown system error -86
    at ChildProcess.spawn (node:internal/child_process:413:11)
    at spawn (node:child_process:700:9)
    at Object.<anonymous> (/Users/me/.nvm/versions/node/v17.9.0/lib/node_modules/mongodb-realm-cli/wrapper.js:22:22)
    at Module._compile (node:internal/modules/cjs/loader:1099:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
    at Module.load (node:internal/modules/cjs/loader:975:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:77:12)
    at node:internal/main/run_main_module:17:47 {
  errno: -86,
  code: 'Unknown system error -86',
  syscall: 'spawn'

Node.js v17.9.0

Hi Anton,

Thanks for posting your issue and welcome to the community!

I used zsh, nvm, and node v17.9.0 but was not able to reproduce this error on realm-cli v2.3.5.

Which realm-cli version are you using?

Also, could you try logging into a different Atlas project with realm-cli and see if it still happens?


Thank you for looking into this.
My issue was that i did a mac transfer from old mac to new M1 which broke few things for me. I had to redo setup from scratch and it worked. –

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.