Unable to find mongosh in latest update

Hi all, unable to find mongosh in latest update, unable to open settings too, can anyone help me with it.

Please update with:

  • Version of compass installed.
  • OS and Version.

I am using Compass Version 1.39.0 (1.39.0) on Mac (M1 chip) Operating system - macos Monterey. I have been using compass since the last 1 year. previously the Mongosh terminal used to be at the bottom most place on the window but its blank in the latest update (attached screenshot)

I am not able to open the settings too, I tried with following way to open the compass settings

  1. Command-Comma (,)
  2. clicking on setting icon at the home page
  3. from Mongodb Compass menubar
    but none of the above methods are working.

Thanks for the quick reply, let me know if you need any other info to look into this issue.

On linux here, so I cannot compare. But mine is certainly showing mongosh at the bottom.

Done the usual ‘turn it off and on again’ trouble shooting?

I also tried on Ubuntu, facing the same problem there, will download the 1.38 version and see if its working.

Downloaded the 1.38 version on Ubuntu and now I can see the Mongosh terminal. i guess the problem is with the 1.39 version only

While it might get attention here on the forums I suggest pop over to jira.mongodb.com and log an issue.

I suspect it could be specific to your installation as there is heavy use of Mac at MongoDB.