Unable to connect to Mongo with Server and Client validation using TLS

I have enabled TLS with server and client validation but unable connect using Compass client, any ideas what this error means and how I can fix it?

Client cert being used is in .cer format.

    mode: requireTLS
    certificateKeyFile: <location of .pem file>
    certificateKeyFilePassword: "<password>"
    CAFile: <location of CA .pem file>

Error message received:

2020-03-24T13:34:25.089+0000 I  NETWORK  [listener] connection accepted from <IP Address:Port number of client> (1 connection now open)
2020-03-24T13:34:25.106+0000 E  NETWORK  [conn180] no SSL certificate provided by peer; connection rejected
2020-03-24T13:34:25.106+0000 I  NETWORK  [conn180] Error receiving request from client: SSLHandshakeFailed: no SSL certificate provided by peer; connection rejected. Ending connection from <IP Address:Port number of client> (connection id: 180)
2020-03-24T13:34:25.106+0000 I  NETWORK  [conn180] end connection <IP Address:Port number of client> (0 connections now open)

Looks like compass is not sending the client cert on connect. I have not used client certs since mongo university and never on Compass.

SSL does need to be set to Server and Client Validation in Compass

Tried the exact same settings as per the screen shot and attached the required certificate .pem files but I still get the same error message. Is there any other way of testing the connectivity to check what is wrong?

You can try it with mongo cli as well to make sure all your certificates are in order/rule out Compass.

A post was split to a new topic: SSL peer certificate validation failed: unable to verify the first certificate