Unable to connect from Mongodb Compass after upgrading the cluster

I upgraded the cluster from Sandbox to M2 (General), and since then I am receiving the following error while connecting from the Compass.

Hostname/IP does not match certificate’s altnames: Host: bridge-cluster-shard-00-00.e75iu.mongodb.net. is not in the cert’s altnames: DNS:*.mongodb.net, DNS:mongodb.net

I can confirm that the network address is set to

Here is the query string that I am using:

Also, my services are able to access the cluster but it just won’t connect from the Compass.

Looks like you’re trying to connect to an individual node in the cluster. Make sure you’re connecting to the cluster address… not a node.

Hope this helps.

I tried connecting after a few hours without changing anything, and it worked!
Thanks anyway.

1 Like

Could be that the cluster was in a transitionary state… you’re definitely better off connecting to the cluster address rather than directly to an individual node, btw. You should look at changing your connection string to the cluster address.