Unable to access Windows MongoDB server via Compass: Connection Timed Out

Good day MongoDB Community,

I have setup a Windows MongoDB server as a service and another PC in the same network going to connect using Compass.

I have updated the bindIp in mongod.cfg as such:

# network interfaces
  port: 27017
  bindIp: 10.xx.xx.xx

I tried connecting via Compass mongodb://10.xx.xx.xx:27017 but connection timed out.
I even added bindIp in Start parameters when running the service but still same result.
Every update, I made sure service is stopped and restarted.

Are there other steps I need to perform to allow the on-premise MongoDB server to be accessed via Compass?

Hi @joseph-d-p ,
From the documentation:
“Make sure that your mongod and mongos instances are only accessible on trusted networks. If your system has more than one network interface, bind MongoDB programs to the private or internal network interface.”

So, you’ve bind the correct nic in your server?
If you haven’ t particular requirement, set the bind ip in this way:

# network interfaces
  port: 27017