Trying to start MongoDB Service with Replication but getting Error 1503

Hello, I apologize If I put this topic in the wrong category.
I am learning MongoDB and I can run my service fine without replication.
My mongod.exe Version is v6.0.7 and MongoDBCompass.exe is v1.38.2

But when I add to my cfg file the following lines

  replSetName: rs0

and try to restart the service I get the Error 1503.

What I did so far:

  • Check Storage and SystemLog Paths and permissions.
  • Check If cfg file have tabs instead of spaces.
  • Uninstall and Install MongoDB.

Am I missing something crucial?

I would appreciate the help, bellow is my edited config file.

P. Costa

my cfg

# mongod.conf

# for documentation of all options, see:

# Where and how to store data.
  dbPath: ...\MongoDB\Server\6.0\data
    enabled: true
#  engine:
#  wiredTiger:

# where to write logging data.
  destination: file
  logAppend: true
  path:  ...\Program Files\MongoDB\Server\6.0\log\mongod.log

# network interfaces
  port: 27017
  bindIp: #, machineIP

  authorization: enabled
#  replSetName: rs0


## Enterprise-Only Options:



Hi @P_Costa

How are you starting mongod? Are you staring it as a service of r invoking it on the command line. The Windows Eventlog may have information if the Windows Service has failed to start.

I note that you have authentication enabled. As such a internal membership authentication method also needs to be used, many installations will use keyfile authentication but X590 is also available.

Hi @chris
I started as a Service, the error that I got is “A timeout was reached (30000 milliseconds) while waiting for the MongoDB Server (MongoDB) service to connect.”
Thanks, I will check out the internal membership authentication maybe it will solve it.

So I made a keyfile and now my service starts.
Now I just need to figure out the final steps to put replications working with authentication and keyfile.

Thanks @chris.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.