Trouble Installing MongoDB: Unmet Dependencies Issue

Hey MongoDB Community,

I’m currently facing a bit of a snag while trying to install MongoDB on my system, and I could use some guidance. Here’s the situation:

I’m attempting to install MongoDB using the command sudo apt-get install -y mongodb-org, but I’m encountering an error related to unmet dependencies. The error message specifically mentions the package mongodb-database-tools as being uninstallable.

Here’s the full error message I’m getting:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 mongodb-org-tools : Depends: mongodb-database-tools but it is not installable
E: Unable to correct problems, you have held broken packages.

I’ve tried a few things to troubleshoot:

  1. I updated my package lists using sudo apt-get update.
  2. I attempted to clear broken packages using sudo apt-get install -f.
  3. I tried to install mongodb-database-tools manually with sudo apt-get install -y mongodb-database-tools, but that failed as well.

I’ve checked the repository configuration and made sure I’m following the instructions correctly, but I’m still running into this issue.

My setup:

  • Operating System: Ubuntu 22.04.03
  • MongoDB Version I’m trying to install: 7.0

Has anyone encountered a similar problem? Any ideas on how to get past this unmet dependencies issue? I’d greatly appreciate any insights or suggestions to help me move forward with the installation.

Thank you in advance for your help!

1 Like

same erorr what cloud are you using , i am using hetzener , u ?

Same problem here. I am installing on my VPS Linux Ubuntu 22.04.03. I’ll try tarball method to see if it’s any better.

Digital Ocean for me, but it doesn’t matter I guess