Stuck on terminate sync - Sync is currently terminating

Realm sync stopped working, asking to Restart Syncing.
When attempting to restart, it did not work.
So we tried to Terminate Sync.
Now the app is stuck with the following message:

Sync is currently terminating…

Please wait for sync to finish terminating before enabling again.

The Enable Sync button is also disabled.

This status has been there for about 1:30 hours by now. Since this is a live application, we would like to resolve this problem soon.
How can we start syncing the application again?

Hi, can you share your app_id / the URL in the browser?

1 Like

This problem appears to be solved for now after notifying the MongoDB support.
But some data is not available according to the GraphQL results. The data is missing from the date when we had a sync failure last week when we were trying to create a flexible sync app and it overloaded the cluster which is in the M10 tier. But earlier we could see the relevant data in the mobile devices which were syncing but not in the MongoDB.
We wish to upgrade to the M20 tier now since there are some sync errors as raised here:
Any help is much appreciated.

Im currently facing the same issue, some help will be appreciated.
App id: ocla-prd-taxms


Hi, looks like you already got into a good place. Unfortunately, terminating flexible sync can take a while since we need to delete a lot of metadata. One of the big improvements of flexible sync is that terminating sync should be almost instantaneous :slight_smile:

Let me know if I can help in any way, but seems like this auto-resolved and the issue is just that it took a bit of time to delete all of the metadata.