Status of Mongod returns core-dump

I’m trying to install mongodb-org following the official installation tutorial here:

The installation itself is fine. It writes to the config files, the mongodb user has write access to the /var/lib/mongodb directory (the log one, too).

I can start the service without any issues. When I check the status, however, (via systemctl status mongod), it says: Active: failed (Result: core-dump)

I initially thought it was a RAM issue, so I quadrupled the available RAM, and the same error keeps happening.

I’ve tried looking online, following multiple Stack Overflow answers and such. It’s a brand-new system, Ubuntu 20.04 LTS.

Is there something I can do about this? Thank you all so much!

The entire response from the status command:

mongod.service - MongoDB Database Server
Loaded: loaded (/lib/systemd/system/mongod.service; disabled; vendor preset: enabled)
Active: failed (Result: core-dump) since ; 4s ago
Process: 30726 ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=dumped, signal=ILL)
Main PID: 30726 (code=dumped, signal=ILL)
Nov 04 19:18:08 systemd[1]: Started MongoDB Database Server.
Nov 04 19:18:09 systemd[1]: mongod.service: Main process exited, code=dumped, status=4/ILL
Nov 04 19:18:09 systemd[1]: mongod.service: Failed with result ‘core-dump’.

I have replaced the date with and hostname with

Most likely the same issue as:


Thank you. It was my CPU.

For anyone else with this problem, try running the following:

  • grep avx /proc/cpuinfo
  • grep avx2 /proc/cpuinfo

If neither print anything to the console, your CPU doesn’t support v5.

You can install version 4.4 from the Version 4.4 MongoDB docs at:

Thank you again.


This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.