SSLHandshakeException : should not be presented in certificate_request

Hi,

i have a springboot application. This application is pluged to MongoDB Atlas with spring-boot-starter-data-mongodb.

The application worked well since 1 year, but, since this morning, without any update, the connexion to the MongoDB has stoped to work.

An error is thrown :

Client view of cluster state is {type=REPLICA_SET, servers=[{address:27017=cluster-xxx-prep-shard-00-02.eocxs.mongodb.net, type=UNKNOWN, state=CONNECTING, exception={com.mongodb.MongoSocketWriteException: Exception sending message}, caused by {javax.net.ssl.SSLHandshakeException: extension (5) should not be presented in certificate_request}}

In the MongoDB documentation i saw this information :
https://mongodb.github.io/mongo-java-driver/4.1/driver/tutorials/ssl/#ocsp-stapling

My application uses JDK 13.0.2.

I don’t know why this issue came this morning
I don’t successful to correct this issue

Any idea ?

Thank a lot

2 Likes

We have the exact same issue… Didn’t find any solution yet. Will keep you updated.

Adding the Java Option -Djdk.tls.client.protocols=TLSv1.2 solved the issue for us.

10 Likes

Hi,

thanks for advice.
if found another solution yesterday.
Java made a fix in different version : https://bugs.openjdk.java.net/browse/JDK-8236039

I have update our java version from 13 to 13.0.5 and there is no more bug.

thanks

2 Likes

I had the same issue but was finally able to resolve it after taking a few simple steps. First I installed the latest JDK(15), then deleted the .m2 folder and rebuild the project using maven command. Though I think the first step was unnecessary, it still worked. Hope this helps.

Hello. I am having the same issue. But don’t necessarily want to switch to JDK15.
I can’t find a package for JDK13.03 or 13.05 on the official Oracle archives.
I’m unsure about adding the Java Option.

Any link to a patched JDK version available ?

Hello, you can find the jdk 13.0.5 at zulu

cordially

Thank you so much !!!
you save our day :slight_smile:

can you plz explain what is the problem?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.