Ssl handshake failed for each node ip's

ssl handshake failed for each node ip’s
but communication between nodes are good.
Please help if we have to change bind ip for this

error is

2021-10-21T07:54:58.175+0000 I NETWORK [conn369] Error receiving request from client: SSLHandshakeFailed: The server is configured to only allow SSL connections.

Welcome to the MongoDB Community Forums @raghu_padaki !

This error message implies that you have configured a mongod or mongos instance to require SSL/TLS, but a client is trying to connect without using SSL/TLS.

To resolve this error you need to ensure all of the members of your deployment and your clients are properly configured to use TLS/SSL.

From the single log line provided it isn’t clear if the connection error is coming from another member of your deployment or a client/driver, but if you grep your MongoDB logs for the connection ID mentioned in this error message (conn369) you should be able to find the associated IP address and connection metadata.

If this info isn’t enough to resolve your issue, please provide further details including:

  • your deployment type (replica set or sharded cluster)
  • the specific version of MongoDB server used
  • your --tls* or --ssl* configuration options
  • the type of connection that is failing (eg a client/driver connection, replica set member, … )

The Bind IP value is unrelated to this error message.