SSH Tunnel not working with Compass 1.21.0

Since the recent update to MongoDB Compass (now 1.21.0, macOS Catalina 10.15.4), it is not able to connect to my remote server using an SSH tunnel.

I use simple username/password authentication for both ssh and mongoDB. The very same parameters worked (and still work) with older version of Compass. Also using pymongo with SSH tunnel forwarder works without any issues - so this seems to be limited to the most recent version of compass in my case. I tried both community edition and the “normal” one.

After clicking on connect and waiting for ca. a minute, I receive the message:


Is it a bug, or does the new version requires any special settings?


I also have the same problem here, can’t login anymore after last update.

I am facing this issue too.
Both with a connection with user/pass SSH Tunnel and other with SSH Identity File.

Screen Shot 2020-05-04 at 10.26.37

It’s astonishing frustrating how Compass can manage to get something broken on every update…

Hi @Peter_Hevesi, @William_Rufino, @hmaesta,

Welcome to the MongoDB Community.

I see that Peter has already raised a bug report for this: COMPASS-4268: Not able to connect over SSH Tunnel any more. The report mentions macOS Catalina 10.15.4; if you are using a different O/S it would be helpful to comment on the Jira issue to help the team identify if this affects ofter platforms.

Please upvote & watch COMPASS-4268 for updates.


1 Like

I’m experimenting the same issue :cold_sweat: and I was wondering if we could rollback to the previous compass version while waiting for a fix.
Is it downloadable somewhere?


Hi @Marco_Mocca, if you know the version that you are looking for you can put that at the end of to get an older version.

Let’s say you wanted Compass 1.16.0 for Mac the correct location would be


You can find all the releases of Compass on Github: Releases · mongodb-js/compass · GitHub


Issue seems to be resolved since 1.21.2 - I tried and on my end and it was working.
Thanks for the quick fix.

1 Like

I’m still getting this on Windows 10. After 1.21.0 I can’t connect using ssh from Compass, but if I make a ssh tunnel using putty or something else and connect to localhost 27017 for example it works.

In Compass the error is connect ECONNREFUSED I don’t specify that port anywhere I’m trying to connect to a default 27017 port but it looks like when using ssh Compass ignores the provided port.

Or am I missing something here?

All of you should switch to NoSQLBooster,
at least that’s what I did (SSH TUNNEL connection with SSH KEYS is still broken for all debian distros)