Spring Boot 4.3.2 upgrade - mongoTemplate bean not found

Hi,
I am trying to upgrade mongodb driver from 3.11.2 to 4.3.2. In the pom.xml, I am using below dependencies

  • spring-boot-starter-data-mongodb 2.5.4
  • bson 4.3.2
  • mongodb-driver-core 4.3.2
  • mongodb-driver-sync 4.3.2
    to avoid referring existing (3.11.2) dependencies, exclusions are also added under the above ones.

The dependency hierarchy structure for mongo driver is
mongoDriver_hierarchy

While running the application, I am getting an error as ‘mongoTemplate required bean not found’.

Does mongo driver 4.3.2 support mongoTemplate ? Do I need to use any alterantives ?
Requesting valuable advice on this