Service 'mongodb server' failed to start. verify that you have sufficient privileges to start system services

Hi !, I’m facing this issue while trying to install the MongoDB community server for learning purposes. I’m using windows 10 node version 18.12.0. I have tried some of the solutions available online but nothing works for me. can anybody please help me out with this? I’ll be very thankful.

Have you choosen default dir path or custom ones?
Check this jira ticket.Some bug associated with shorter dbpath dirs

or it could be due to a missing dll or lack of admin privs or some invalid entry in cfg file like #mp
Also check stackoverflow threads on this topic

I choose the default path while installing the DB, and I’ve tried most of the solutions online like on StackOverflow but it didn’t work for me. I’ve all the admin privileges and also checked the mongod.cfg file but could not locate anything like #mp in it.

My issue got resolved. I followed some processes mentioned on StackOverflow and it worked. Thanks for your support Ramachandra.

And what helped?
I have the same issue with 5.0.16 upwards

Hi @L_Z , you can refer to this link: installation - Service 'MongoDB Server'(MongoDB) failed to start.Verify that you have sufficient privileges to start system services - Stack Overflow

My issue were multiple Windows Server Users, I used the right one then it worked.