Schema view not working

When I click on the analyze schema button, it loads and then it shows only a blank screen.
Can anyone help?

I had this happen to me once when working with the schema for “citibike.trips”. It never finished populating the screen. Did you try restart your session?

Yes, I restarted the session several times.

I had the same problem. Restarting Compass worked for me.

1 Like

when I first open mongodb-compass I can get to the schema for video.movies, everything else fails thus far

If I go look at something else, then come back to video.movies, then the schema is gone and won’t come back

sampling collection
analyzing documents

then a blank pane

even for ships.shipwrecks with only 11k documents

this is frustrating as the course depends on the tool, but the tool is not working

restarting compass is not resolving the issue, neither did rebooting

I am running Compass on MacOS. I only hit a problem once when loading the documents tab for the citibikes.trips collection, but apart from that all is working fine working from home or the office.

Have you tried re-installing Compass? Can you install Wireshark and run a packet trace that filters on port 27017 (filter would be tcp.port == 27017)? The trace would allow you to see if the load is stalling.



Hi @Haroon_54223,

You can try restarting Compass and ensure that you have good internet connection. Please share the screenshot of Compass Schema section and also the let me know the operating system that you are using.


After I click the analyze schema button.

I’m currently using Windows 8.1 64bit and I have a good internet connection.

Also I have

1 Like

Hi Lunfthans, i am also facing the same problem.
How you resolved this issue ?
Can you please help in this !

Share a screenshot of your version of Compass.
Share a screenshot of the problem.

I cannot access Schema View.

What is your Compass version?
Please use stable version

Hi @Saurabh_14148,

It looks like a temporary network issue to me. If you are still facing this problem then please share the following information.

~ Shubham

Hi @Dakshitaa_31561,

I hope you found @Ramachandra_37567’s response helpful. Please download the latest stable version of Compass.

Please feel free to get back to us if you are still having any issue.

~ Shubham

Hi Shubham,
Thanks,it working now

Hey @Shubham_Ranjan,
I have the same problem as @Dakshitaa_31561 but I already have the latest stable version. I also already re installed it, but it still does not work properly and is showing me any schema tab.

Do you or someone else knows, where there could the be the worm in the program.

You have the latest Community edition but you don’t have the latest Stable version.

Hi @Chris_46845,

This :point_down:

~ Shubham

Okay :man_facepalming:,
well at least the penny dropped now.
I saw now yet, that there are different 1.20.5 Versions, that wasn’t that clear for me till now.