Schema View not loading

I have been trying to visualize the 100YWeatherSmall Schema and it is not loading for two days now despite the fact that my connection to the Compass Cluster is intact. Please help me out.

It should work
Did you try restart of compass
Is your internet connection fine

Same issue here…Even tried restarting the MongoDB compass…It throws an error - connection 47 to cluster … timed out.

Hello all same applies for me as i am going throught the course scema is not working as view is not getting displayed

1 Like

Yes, I restarted Compass several times.
My internet connectivity is fine.

1 Like

May be firewall/gateway issues or compass version/internet speed
Is schema working for other databases?
Make sure you are connected to class cluster–>100YWeatherSmall–>data

Working fine for me

This is the view I have on my screen despite other Schema views are loading the 100YWeatherSmall is still blank.
This issue will make it difficult for me to turn in my Lab answers.

I tried again today and this is my screen view.
The red label reads "An error occurred during Schema analysis: connection 9 to timed out


Hi @Olawale_31333,

Please make sure you are using Compass latest version(1.18.0 Stable). You can download the latest version from here.
Moreover, are you using 64 bit system?

Also, try reinstalling Compass.

Please let me know, if you still face the same issue.


Yes, I am using a 64-bit system. I actually installed Compass latest version (1.18.0) the stable edition I will uninstall now and re-download the installer.
I will revert once that is done.
Thank you Sonali.

1 Like

Hello Sonali,
Below is the screenshot of the error I am still experiencing despite re-installing Compass.
I deleted the profile favorites and started afresh but still the same issue.

I conducted an internet speed to test my connectivity as well, the screen shot is below;

Hi @Olawale_31333,

Please try solutions mentioned in the following posts:

Also, let me check this issue on my end too. I will update you if I have solution as soon as possible.


I have the issue with the schema not loading - just continuously analyses and never returns or times out - get a message to the effect its taking longer than expected- hitting the ‘Stop and Show Partial Results’ stops the analysis but doesn’t show anything and I can’t restart the analysis without restarting compass.

I am able to browse the documents and see the record information.

All of the example databases are the same.

I Have tried running as administrator without effect.

Hello Sonali,
Thanks for your support but it did not work eventually. I ended up not able to turn in two of my Lab questions.
Will references be made to the schema analysis view later in the course?
Thank you.

Hi @Olawale_31333,

I would recommend you to proceed further with the course as Schema analysis will not be required in the later part of the course.

I have already forwarded this issue to the Compass Team. I will update you as soon as I get any updates regarding this issue.

Please let me know, if you have any questions.


Hi @Phill_40649,

This seems like an issue with the internet connection.

Are you not able to view Schema even once or does restarting Compass helps at times?


Hi Sonali,

I’ve never been able to view the schema for any database - I have no issues at all with any of the other tabs in Compass.

The Port 27017 is open otherwise I would not be able to browse the databases, does the tab use any URL referals or other ports as these may be blocked by our firewall, if so what are they so I can get them whitelisted.



1 Like

Hi @Phill_40649,

I believe you are also facing issue similar to @Olawale_31333.
Please proceed further with the course as Schema Analysis is not required in the later labs/questions.

I will update you as soon as the issue is resolved from our end.



Hello Sonali_48808,
Thank so much for your assistance. I have continued with the second Chapter of the course.
I appreciate you timely response.


1 Like