Recover Mongodb instance 4.4 without WiredTiger.wt


My old ssd recently broke a bit and I still have a mongodb instance there (I will call it the old instance). Its running a 4.4 Mongodb server and I still need a very important database.

I thought I could basically xcopy the whole directory onto my new ssd but it seems like that my old ssd can’t read the WiredTiger.wt file. Still copied the rest over and tried running that instance but it seems like that only the default databases (admin, local, etc) were shown to me, not the other databases.

I tried running the old instance on the older harddrive but the same problem kept appearing.

One idea I thought of was to understand the WiredTiger format and implement it in some Python Code so I could eventually recover some data but I couldn’t really find any good resources for that format.

It would be really nice if you could help me out.

Hi @Ari_24 welcome to the community!

It’s unfortunate that the corrupt file is WiredTiger.wt, since this file contains important information about all the other wt files in the dbpath.

If you haven’t tried it yet, I recommend you try the repair procedure detailed in Recover a Standalone after an Unexpected Shutdown. Please also ensure that you follow all the warnings in that page, since this method is a last resort.

Best regards

1 Like