Realm syncs from iOS not showing up in Compass

I’ve used Realm for a few months and just started trying Mongo Realm this week.

I’m working on an iOS app.

I can log in to my Mongo Realm database and write to a collection.
I know it is syncing because I run the app on two different devices and the data synchronizes whenever the object is edited on either iOS device. Yeah!


I don’t see the data I created in iOS on my MongoDB Compass app.
I don’t see the data I imported in Compass on my iOS app.

In the browser, on I see the data I imported in Compass.
On I see logs indicating syncs from the iOS modified data, but nothing downloading the larger collections imported into Compass.

In my app, every object has an uuidUser key and an UUIDFamily key. I’m using the uuidFamily key as my partition value for syncing.

Any suggestions on how to get data from Compass into iOS?

@Adam_Ek Do you see the data in the browser Atlas Collection explorer when you click Atlas >Your cluster > Collections ? If not can you try Pausing an Resuming sync

I have experienced this same issue. The data does not show up in Compass or in the Atlas collection. However, the data is being updated as evidenced by viewing on different devices.

For example, I added several documents, then used realm.create to update some of the properties. The updated properties synced to two devices, but did not appear in Compass or Atlas Collections. I logged out of both and logged back in, no change.

I was able to get the data to update in both Atlas Collection and Compass by going to the Realm App page and pausing then resuming Sync.


Still not syncing from cloud to device.

I can see the data in browser and Compass, but not on iPhone, but iPhone and iPad will sync to each other.

@Adam_Ek @Rob_Cummings If you are still not seeing data show up in your Atlas cluster after pausing/unpausing sync can you please email with a link to your Realm app on MongoDB Cloud and I will have a look

What’s your email address?

Ha! That would’ve been helpful wouldn’t it? :smiley:

I’ll add my two cents. I’ve been doing the iOS Task Tracker tutorial and I’m seeing some of the same behavior. It syncs between simulator devices but when I look at the data in Compass or in the console I have two tracker.users document (that’s true) but nothing for tracker.tasks (there should be three) or tracker.projects (should be one).

Hello everyone !

I’m working on an iOS app too and I have exactly the same problem as @Adam_Ek. I tried to pause & restart sync as @Ian_Ward said but still not working.
Is there any update about this problem? Did anyone find a solution?


@Julien_Chouvet Please email me with the URL to your Realm app and I can take a look

I think I’m running into this issue as well @Ian_Ward
I’ll send an email with the app URL

I appear to have the reverse
I have records in the Atlas collection
Running Realm UI rules -> Validation they validate
But they do NOT show in iOS when reading all objects realm.objects(…

collection has 798 records for username:“xyz” but realm.objects for partition “xyz” only has 768 30 missing records.

Any ideas

Count us in as well - sync issues both directions.

Sometimes we add a Task in the app, which displays but it won’t sync up to the server. Other times we’ll have items on the server than won’t sync down to the app - there may be 10 items showing in the console but it only shows 6 in the app.

As a test, yesterday we deleted everything in console and removed all local files related to tasks. This morning I added three tasks in a row - all three showed perfectly in the app and in console.

I quit the app, re ran the app and added one more. It shows in the app but not in the console.

It went downhill from there as we are now seeing errors in the console and nothing syncs at all.

Was there ever a solution to this?

I can read data from the collection (that is “pre” written to the collection)
I stores locally
I can write and read to the local realm DB realm.objects has multiple entries

However, What I write locally (iOS) is never seen in the collection (using Compass and Atlas)

That could be a coding issue or it could be related to an existing server issue.

I would suggest running your app and inspecting the logs within the MongoDB Realm console to see if you app is communicating to the server and if so, see what kinds of errors you’re seeing in the logs.

I’m experiencing similar issues with tasks not appearing in either Atlas or Compass. I went ahead and sent you an email with the information requested.

It seems fixed in the latest version.

We are facing a similar issue. Already pause and re-enable sync. Didn’t help. Is there a solution?

There are a number of possible reasons (most of them due to a misconfiguration, a schema error, etc.), so there isn’t a single fix for everyone. In general, a look at the logs (either on the backend, or in your client app) will inform of any issues found, and once you’re aware of what’s happening, typically the solution isn’t far away.

Thus, if you have errors in the logs, the right thing is to start from there.

Otherwise, if you have a Support Contract, the best way is to open a case, and it will be followed properly: the alternative is to let us have the reference for your app, that may not be appropriate to put in a public forum.