Realm Sync lost schema - allows sync download but not changeset upload?

So yesterday when I tried to upload some changes through Realm Sync, I got a “bad changeset” error:

Puzzled by the error (since I had extracted my C# schema objects via the web interface), imagine my surprise when I looked at the schema using Realm UI:

What happened to my schemas??!

Strangely, I was still able to download a fresh sync to the client (i.e. delete local Realm and re-run application). I just couldn’t upload any updates.

This morning I tried a “re-deploy” of my most recent schema change from github, via the Realm UI “Deployment” page. Fortunately, that seems to have fixed it. But if this happens when my app is in production use…?!

What happened here, I wonder?

Can you file a support ticket at The team there would be best equipped to investigate the issue and make sure it doesn’t reoccur.

Well, I did try emailing them but all they told me was that they couldn’t help me because I’m not a paying customer… :confused:

@polymath74 Yeah if you dont have a support contract you won’t be able to open a support ticket in the web portal but there should be a chat widget in the Cloud UI which you can start a chat and if its a bug on our end we should investigate regardless of whether you have a support contract.

For this specific issue, have you been able to reproduce this? When did this occur?


Hi, apologies for this. I have taken a look at your issue and diagnosed that it was an issue on our side but it has been resolved.

We performed a migration of where schemas were stored and had code to temporarily handle API requests modifying the schema while the migrations were occurring, but it looks like there was a small oversight in a specific path of using the CLI to update schemas that was missed which resulted in you losing your changes during this time window that the migration was taking place. Im glad you were able to re-export your app and all is good. I can confirm this will not be a usual thing given that this migration took place and is now in the past.

Again, sorry for this inconvenience, but we are excited for some future improvements to the schema experience that this migration will enable.