Realm plugin incorrectly causes error in compileDebugJavaWithJavac gradle task

I have documented this as an issue here, and have had some conversation with ‘cmelchior’ within that issue, but there has been no follow-up for many days now. This bug is causing me to do a full rebuild nearly every time I make even the most trivial change.

It is still giving the issue in the latest stable AS (Arctic Fox 2020.3.1 patch 1)

Is this being actively reviewed? As stated in the issue, I’m more than willing to do a live review of the project I have which is showing the error if that will help. Unfortunately, I can’t simply upload the entire project, and I tried once to make a simple example project that would reproduce the error but I have not been able to do that.


Sorry for the lack of updates. The issue has not been forgotten, but another bug took priority. It has been solved now, and I intend to to look into this issue this week. You can follow the Github issue for updates.

1 Like

Hi @ChristanMelchior -

Just wondering what the status of this is? The Github issue hasn’t been updated, and its been a couple weeks since our last communication. Can you give an update?