React-native debug build for android throwing "pod install" error


I have been trying to build my Android app using React-NAtive and failing since an error follows,

My IOS build is successful, but android shows this,
I have installed pods and checked for them.

Please help

1 Like

Hi I have the same problem. Are you using Expo app or have you tried with react native app too? Do you use typescript or only javascript? I dont know if it can be a factor, just want to see which environment the problem appears in .

You can try to disable RN New Architecture as I assume you are not running v12.0.0-alpha.2.

1 Like

Thank you! Sorry about the late reaction. I am back again to realm . So in my case it seems the case was simple. I tried to use realm in developement and with expo go on real device. Howver I read its only working in production and after the build of the app as Expo Go is not compatible with third party libraries and so with Realm. Now after the build my application is started smoothly in expo and on its android emulator.

So just install realm and try npm start android in your app folder.

  • npm start android ( “android”: “expo run:android”, in the package.json scripts )
    “scripts”: {
    “start”: “expo start --dev-client”,
    “android”: “expo run:android”,
    “ios”: “expo run:ios”,
    “web”: “expo start --web”