ODBC manager needs to be updated error?

I recently posted about the struggles with installing BI ODBC connector from https://github.com/mongodb/mongo-bi-connector-odbc-driver and thanks to their new version V1.4.3 I was able to successfully install the package but the issue now is that I cant open the ODBC manager .

Everytime I try opening it, I get the following prompt:

Blockquote

ODBC Manager needs to be updated. The developer of the app needs to update it to work with this version of macOS. Contact the developer for more information.

Is there anyway I can sort it out on my end? I am running MacOs 12.4.