ODBC Connection test not responding

I have installed mongo DB in Linux operating system(CentOS 7), I am configuring ODBC 32 bit connection in windows machine, when I test it is not responding, I have tried ODBC 64/32 bit and also tried with unicode and ascii option. I am not sure with what i am doing. I have also attached screenshot for connection details. Logs are not generating. Do i miss any configuration in ODBC like TLS or SSL?

Welcome to the community @Vidya_Sagar_Reddy,

The MongoDB ODBC Driver for BI Connector also requires a compatible version of the MongoDB Connector for BI to be installed and running.

What are your installed versions of MongoDB ODBC driver, Connector for BI, and MongoDB server?


Sorry for Late reply,

mongo --version
MongoDB shell version v4.2.7
git version: 51d9fe12b5d19720e72dcd7db0f2f17dd9a19212
OpenSSL version: OpenSSL 1.0.1e-fips 11 Feb 2013
allocator: tcmalloc
modules: none
build environment:
distmod: rhel70
distarch: x86_64
target_arch: x86_64

cat /etc/os-release
NAME=“CentOS Linux”
VERSION=“7 (Core)”
ID_LIKE=“rhel fedora”
PRETTY_NAME=“CentOS Linux 7 (Core)”


BI Connector Version: 2.13.4

ODBC Driver: Tried with all possibilities 32/64 bit and 1.0/1.4(ascii/unicode)

Thanks so much - I had a similar issue to this thread but it was because I didn’t have the compatible version of the Connector for BI.

@Marty_Zager, Could you please share me your compatible version for below list and let me try it out,

  1. mongo --version
  2. BI Connector Version
  3. ODBC Mongo DB version.
  4. Unicode or acsii

I’m also facing the same issue, could you please share us detailed resolution here.

So far have tried using Mongdb driver version 1.0 and 1.4 but no luck.


The MongoDB BI Connector connects to the MongoDB server on port 27017 and will bridge the NoSQL nature of MongoDB and make its data visible as sort of virtual tables. ODBC driver then connects to the MongoDB BI Connector, typically on port 3307.
so try 3307 instead 27017