O-fish web error: Cannot use 'in' operator to search for 'realmBaseUrl'

Hi all,

This is the first time I’m contributing, and I’m currently looking at https://github.com/WildAid/o-fish-web/issues/210

Unfortunately, I haven’t gotten past the setup.

I’m trying to build the o-fish-web using the sandbox, but I keep getting this error.

Also tried building my own instance, but got the same error

Sandbox: https://wildaidsandbox-mxgfy.mongodbstitch.com/
admin user: lenmorld@gmail.com
Realm App ID: wildaidapp-tqiou

Where do I get the realmBaseUrl ?
Any workarounds?


Hi @Lenmor_LD!

I’m sorry you’re having struggles. The realmAppIdcomes from src/config.js.

Things to check:
Did you copy src/config.js.tmpl to src/config.js?
Did you replace the line:
realmAppId: ‘’,
realmAppId: ‘wildaidsandbox-mxgfy’, # for the sandbox
realmAppId: ‘wildaidapp-tqiou’, # for the build you did

Hi @Sheeri_Cabral,

Thanks for the response.

I have the realmAppId.
But it keeps looking for a realmBaseUrl, which I don’t have in my config.
It’s also not in the provided config.js.tmpl

I tried removing the code that uses it in stitch.service.js,

…but then I get a different error

Should I post this as an issue in case anyone else can repro?


Hi Lenny,

I was able to reproduce the issue if I checked out the code, copied src/config.js.tmpl to src/config.js, and built, without adding any custom information to the src/config.js file:

When I change the realmAppId line to have the sandbox, the build works fine…
so I changed
realmAppId: ‘’,
realmAppId: ‘wildaidsandbox-mxgfy’,
and ran npm start again.

Here’s what my config file looks like after the change:

Hope that helps!

Thanks @Sheeri_Cabral
That definitely helps.
I examined by config copy, and realized that I had the wrong file extension on my config.js, which was definitely an overlook on my part. :man_facepalming:

I’m able to build it now, and ready to work on my issue. :smile:

Thanks a lot for your help!

I’m so glad you got it working!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.