Need help plis ASAP

Hi there! Hope you can help me to install mongodb in centos 7 with arquitecture x86_64 please.
when i run the next comand:
sudo systemctl status mongod
i receive the following:
mongod.service - MongoDB Database Server
Loaded: loaded (/usr/lib/systemd/system/mongod.service; enabled; vendor preset: disabled)
Active: failed (Result: core-dump) since Sun 2024-05-26 00:05:40 CDT; 7min ago
Docs: https://docs.mongodb.org/manual
Process: 3911 ExecStart=/usr/bin/mongod $OPTIONS (code=dumped, signal=ILL)
Main PID: 3911 (code=dumped, signal=ILL)

mongod.service: main process exited, code=dumped, status=4/ILL
Unit mongod.service entered failed state.
mongod.service failed.

reading about the problem is because the version of mongdb, but i have tried with versions: 7, 6 and 3.4 and with all of them i get the same error.
and other issue i got is
mongod --version
Illegal instruction (core dumped)

please help me

ILL means illegal instructions
May be you are using old cpu archtecture?
Check this link/production notes platform support matrix

Error start mongodb centos7

hi, thanks for answering me
i’m using
CentOS Linux release 7.2.1511 (Core)
Model name: Intel(R) Xeon(R) CPU E5649 @ 2.53’GHz
what could be the next step, what version do i have install ?