My project uses the Realm SDK for Node running in a Docker container. I will provide the details below. My issue is about an error thatفرصتك جلب الحبيب الدفع بعد النتيجة 00905340776958 شيخ روحاني في قطر واتساب آدم عزرةthe service starts, I get the erro

Deprecationشيخ روحانيWarning: The punycode module is deprecated. Please use a userland alternative instead.
2024-02-18T03:28:55.593Z] INFO 2085b3454158-18/REGISTRY: Discoverer: LocalDiscoverer

[2024-02-18T03:28:55.599Z] INFO 2085b3454158-18/BROKER: Serializer: رقم ساحرJSONSerializer
[2024-02-18T03:28:55.687Z] INFO 2085b3454158-18/BROKER: Validator: FastestValidator
[2024-02-18T03:28:55.705Z] INFO 2085b3454158-18/TRACER: Tracing: Enabled
[2024-02-18T03:28:55.710Z] INFO 2085b3454158-18/TRACER: Tracing exporter: ConsoleTraceExporter
[2024-02-18T03:28:55.729Z] INFO 2085b3454158-18/BROKER: Registered 13 middleware(s).
[2024-02-18T03:28:55.740Z] INFO 2085b3454158-18/TRANSPORTER: NATS lib version: 2.19.0
[2024-02-18T03:28:55.750Z] INFO 2085b3454158-18/BROKER: Transporter: NatsTransporter
[2024-02-18T03:28:56.311Z] ERROR 2085b3454158-18/BROKER: Failed to load service ‘/app/services/servicerealm.service.js’ Error: Cannot find module ‘…/generated/ts/realm.node’
Require stack:

  • /app/node_modules/realm/dist/bundle.node.js
  • /app/node_modules/realm/index.node.js
  • /app/services/servicerealm.service.js
  • /app/node_modules/moleculer/src/service-broker.js
  • /app/node_modules/moleculer/index.js
  • /app/node_modules/moleculer/bin/moleculer-runner.js
    at Module._resolveFilename (node:internal/modules/cjs/loader:1149:15)
    at Module._load (node:internal/modules/cjs/loader:990:27)
    at Module.require (node:internal/modules/cjs/loader:1237:19)
    at require (node:internal/modules/helpers:176:18)
    at Object. (/app/node_modules/realm/dist/bundle.node.js:151:22)
    at Module._compile (node:internal/modules/cjs/loader:1378:14)
    at Module._extensions…js (node:internal/modules/cjs/loader:1437:10)
    at Module.load (node:internal/modules/cjs/loader:1212:32)
    at Module._load (node:internal/modules/cjs/loader:1028:12)
    at Module.require (node:internal/modules/cjs/loader:1237:19) {
    code: ‘MODULE_NOT_FOUND’,
    requireStack: [ ‘/app/node_modules/realm/dist/bundle.node.js’, ‘/app/node_modules/realm/index.node.js’, ‘/app/services/servicerealm.service.js’, ‘/app/node_modules/moleculer/src/service-broker.js’, ‘/app/node_modules/moleculer/index.js’, ‘/app/node_modules/moleculer/bin/moleculer-runner.js’ ]
    }
[/quote]

 "dev": "NODE_ENV='development' moleculer-runner --repl --hot services/**/*.service.js",
    "start": "moleculer-runner",
    "cli": "moleculer connect NATS",
    "ci": "jest --watch",
    "test": "jest --coverage",
    "lint": "eslint services",
    "dc:up": "docker-compose up --build -d",
    "dc:logs": "docker-compose logs -f",
    "dc:down": "docker-compose down",
    "dc:vc": "docker volume ls -qf dangling=true | egrep '^[a-z0-9]{64}$' | xargs --no-run-if-empty docker volume rm && docker image prune",
    "dc:img": "docker buildx build --platform linux/amd64,linux/arm64,linux/arm/v7 -t nexarsys/nexarflow-backend:pwa-2.0.0 --push .",
    "dc:dg": "docker buildx build --platform linux/amd64 -t nexarsys/nexarflow-backend:pwa-2.0.0 --push .",
    "dc:file": "docker buildx build --platform linux/amd64,linux/arm64,linux/arm/v7 -t nexarsys/nexarflow-backend-file:pwa-2.0.0 --push -f Dockerfile-file ."
  },