Multiple text records not allowed

Getting this error when trying to connect to Atlas

Make sure you replace <password> with your real password.

The error Multiple text records not allowed seems to indicate erroneous DNS information. However, according to:

;QUESTION
cluster0.apq2bmf.mongodb.net. IN ANY
;ANSWER
cluster0.apq2bmf.mongodb.net. 60 IN TXT "authSource=admin&replicaSet=atlas-geo4a7-shard-0"
cluster0.apq2bmf.mongodb.net. 60 IN SRV 0 0 27017 ac-zx4ig6e-shard-00-00.apq2bmf.mongodb.net.
cluster0.apq2bmf.mongodb.net. 60 IN SRV 0 0 27017 ac-zx4ig6e-shard-00-01.apq2bmf.mongodb.net.
cluster0.apq2bmf.mongodb.net. 60 IN SRV 0 0 27017 ac-zx4ig6e-shard-00-02.apq2bmf.mongodb.net.

it looks fine.

@Ananthan_Rajasekharan have you been able to resolve the issue? If not, could you please let me know which version of Compass you are using and what you are connecting to (sharded cluster, M0, etc.)?

Feel free to message me directly if you do not feel comfortable commenting these details publicly.

Sorry for the late reply.

I was not able to resolve the issue. The version I used is 1.32.6-win32-x64 and also 1.32.6-beta.4-win32-x64. Both showed the same error.

I kind of feels like its my internet connections problem (not sure though), I will tell after testing

Try using Google DNS 8.8.8.8

Tried the Google DNS, same result.

I tried using MongoDB Shell to connect via one of the instances I have on digital ocean, and when I tried there it works. Its not working on my computer. I have no clue as to why.

Make sure you allow access from anywhere in network access.

facing same issue, using google DNS 8888 and 8844, and facing this issue on sharded cluster, M0