MongoDB tools do not accept a connection string with proxy options

I am following up to the following thread about mongosh:

It was mentioned that (correctly) you may use the &proxyHost and &proxyPort parameters in the MongoDB connection string, to connect to a MongoDB using mongosh. However I tried to use the same (working) connection string using mongodump (version 100.7.0), but I am getting the following warnings:

2023-05-15T11:37:01.798+0200 WARNING: ignoring unsupported URI parameter ‘proxyhost’
2023-05-15T11:37:01.800+0200 WARNING: ignoring unsupported URI parameter ‘proxyport’

Is there any reason why or workaround how to get the proxy options working for mongodump? Thanks.

1 Like